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HHOOWW--TTOO
Written by David D Lowe

GGNNOOMMEE--LLOOOOKK  GGUUIIDDEE

When I first joined the 
Ubuntu community, I 
was extremely 

impressed with the amount of 
customization Ubuntu had to 
offer. People posted impressive 
screenshots, and mentioned the 
themes they were using. They 
soon led me to gnome-look.org, 
the number one place for GNOME 
visual customization. The 
screenshots there looked just as 
impressive, but I was very 
confused as to what the headings 
on the sidebar meant, and I had 
no idea how to use the files I 
downloaded. Hopefully, this guide 
will help you learn what I found 
out the slow way.

This should be self explanatory. 
Wallpapers are what you decorate 
the background of your desktop 
with. Click on a wallpaper, and 
then click on the download link, 
and save the image to the 

harddisk, say, ~/Pictures/Wallpapers.
You may have noticed that gnome-

look.org separates wallpapers into 
different categories, according to the 
size of the wallpaper in pixels. For 
the best quality, you want this to 
match your screen resolution. If you 
don't know what your screen 
resolution is, click System > 
Preferences > Screen Resolution. 
However, Ubuntu stretches 
wallpapers quite nicely if you picked 
the wrong size, so you needn't fret 
about it.

SVG is a special image format that 
doesn't use pixels; it uses shapes 
called vectors, which means you can 
make it as big as you want without 
losing quality. Don't hesitate to use 
these.

After you've finished downloading 
the wallpaper, simply open it in the 
image viewer, and click Image > Set 
as wallpaper.

You can also set your wallpaper by 

right-clicking on your desktop 
and selecting the appropriate 
button (you know which one!).

Don't let acronyms intimidate 
you; you don't have to know 
what the letters stand for to 
know what it is. Basically, GTK is 
the system GNOME uses to 
display things like buttons and 
controls. GNOME is Ubuntu's 
default desktop environment. I 
will only be dealing with GNOME 
customization here--sorry 
Kubuntu and Xubuntu folks!

Gnome-look.org distinguishes 
between two versions of GTK: 
1.x and 2.x (x stands for any 
number). Ubuntu Hardy Heron 
can use both kinds, but I 
recommend GTK 2.x, as Ubuntu 
prefers this upgraded version.

Before we continue, let me 
make an important distinction 
between GTK themes and GTK 

http://gnome-look.org
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engines. Unfortunately, gnome-
look.org categorizes both of them 
as theme/style, but you'll see why 
in a minute. GTK engines extend 
default GTK-theme functionality. 
They are like programs and are 
installed like programs: do a 
search for gtk-engines in synaptic 
and see for yourself. GTK themes 
style your controls; they usually 
depend on an engine. One engine 
can have lots of themes, and one 
theme can be re-done for several 
engines and made into several 
themes.

The reason why gnome-look.org 
lists both as theme/style is 
because an engine usually comes 
with a default theme named after 
the engine. Clearlooks, for 
example, is the name of both an 
engine and a theme.

All of the most popular engines 
are already installed by default in 
Ubuntu, so unless a theme's 
description specifically says it 
needs a specific engine, you don't 
need to worry about it. So pick a 
GTK theme and download to your 
hard disk. Then install by clicking 
System > Preferences > 

Appearance > Install. Click 
Customize and your new theme 
should be listed under the Controls 
tab.

GTK themes are usually 
compressed with the .tar.gz filename 
extension.

Metacity is the program that 
displays window borders, basically 
the title-bar including the minimize, 
maximize and close buttons (above). 
Window borders are also called 
window decorations. Metacity is used 
by default in Ubuntu for all the 
window borders. Alternatives include 
Emerald, which I'll cover later.

Metacity themes are pretty simple, 
for once :) . Just choose one, 
download it, and install it by clicking 
System > Preferences > Appearance 

> Install, and find it by clicking 
Customize > Window Border. 
That's it!

Metacity themes have the 
.tar.gz filename extension.

Compiz Fusion is what's used 
when you enable visual effects. 
It has an insane number of 
options, which you can access 
by installing the compizconfig-
settings-manager package from 
the repositories. All sorts of 
customizations for Compiz are 
shared on gnome-look.org in just 
one category, but I'll separate 
the main ones here:

 like 
metacity, Emerald is a window 
decorator (above). However, it 
has more effects then Metacity, 
such as transparent title-bars. It 
requires Compiz and is not 
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installed by default. To use it, 
simply install the 'emerald' 
package from the repositories, 
press alt-F2, and type 'compiz - -
replace' (that's two dashes). If 
you want to use this window 
decorator by default, launch 
Advanced Desktop Effects 
Settings (System, Preferences), 
click on the window decorations 
plugin, and change command to 
'compiz - -replace'.

 download it, 
click System > Preferences > 
Emerald Theme Manager, click 
'Import' and open your 
downloaded file. Click on a theme 
to apply it. Emerald themes have 
a .emerald extension.

 Skydomes are 
background images for Compiz's 
cube plugin. Setting up the cube 
is beyond the scope of this guide 
but skydomes aren't. Simply 
download the skydome, click 
System > Preferences > 
Advanced Desktop Effects 
Settings > Desktop Cube > 
Appearance > Skydome and tick 
the 'Skydome' checkbox. Click on 

the open button to load your 
skydome.

If your skydome doesn't load, don't 
worry, try another one. Compiz may 
refuse your skydome because it 
doesn't fit your screen, or because it 
is too big for your memory (I think!). 
Skydomes are image files so they 
have .jpg or .png file extension.

Beryl used to be a competing 
project to Compiz, but now they've 
merged into Compiz Fusion, which 
Ubuntu uses by default, so I'll skip 
this section.

Gnome-look.org divides the icon 
category into two sub-categories: 

Icons: these are just simple, 
single icons. You can find the 
GNOME logo here, for example. 
Icon themes: these interest us 
more. Each icon theme tries to 
customize a maximum number 
of icons on your system, so don't 
be surprised if your application 
logos your file type icons and 
your commonly used action icons 
change. Installing them is 
simple: just download an icon 
theme (or icon set), click System 
> Preferences > Appearance 
then Install and open your 
downloaded file. You can find 
your icon theme by clicking 
Customize > Icons.

Icon themes are the biggest 
files on gnome-look.org, and 
they have the .tar.gz extension.

GDM is the login screen 
system that comes installed by 
default in Ubuntu. If you're tired 
of the brown default one, or you 
want one with a face browser 
(shows a list of users), you can 
install other ones. Simply 
download one to your liking, click 
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System > Administration > Login 
Window > Local > Add, and open 
your file. There are other options, 
such as randomly selecting a 
different login screen every 
session, which I'll let you explore.

By the way, did you notice that 
the login preferences window 
didn't have the same theme as 
the one you have on your 
desktop? That's because you ran 
it as root, and root has its own 
preferences for its themes.

GDM themes usually have the 
.tar.gz extension.

Unfortunately, gnome-look.org 
doesn't distinguish between 
different types of splash screens 
(above), and incorrectly 
categorizes them all as GNOME 

splash screens, but I won't.
 if you have 

more than two systems installed, say 
Ubuntu and Windows, and are dual-
booting, then on every boot you are 
shown a list to choose from. By 
default, Ubuntu uses grub, with a 
menu that is black and white and 
ugly. However, you can add a 
background image to the grub 
bootmenu so you can feel good from 
the first few seconds after you turn 
the computer on.

 after 
you select Ubuntu from the grub 
menu, Ubuntu will proceed to load, 
while displaying the Ubuntu logo and 
a simple progress bar. You can 
replace this with another splash 
screen of your choosing.

some of 
you may remember the days when 
this was enabled by default. A small 
window would appear after logging 
in, showing the icons of programs 
being loaded. If you want, you can 
bring it back.

First, make sure you have gnome-
splashscreen-manager installed from 
the repositories. Select a GNOME 

splash screen and download it. 
Click System > Preferences > 
Splash Screen, click 'Install' and 
open your downloaded file. Make 
sure 'Show splash screen on 
startup' is ticked, and you're 
done!

GNOME splash screens are 
images, and have .jpg or .png 
extensions.

If you have installed gdesklets 
from the repositories, then you 
might be looking for more 
desklets than the ones that 
came by default. You can find 
them here. Installation is as 
simple as downloading the file, 
and then clicking File > Install 
Package from the gdesklets 
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manager. Gdesklets are simple 
desktop widgets that provide lots 
of different functionality.

Gdesklets generally have the 
.tar.gz extension.

Screenlets is a more up-to-date 
widget system for Linux and 
competes with Vista gadgets, as 
well as gdesklets. Screenlets is 
available in the Hardy Heron 
repositories. Download a screenlet 
from gnome-look.org, and install it 
using the 'Install Screenlet' button 
in the screenlets manager. You 
should be getting used to this by 
now!

Screenlets have the .tar.gz 
extension.

XMMS is a media player for 
Linux, and it has its own theme 

system. You can download some 
custom themes for it from gnome-
look.org.

A place where people have 
uploaded screenshots of their 
desktops to show them off. We are, 
of course, impressed.

Fonts are also called typesets. 
They determine what text looks like. 
Popular fonts you might have heard 
of are Times New Roman and Comic 
Sans MS. Both of these are Microsoft 
fonts and can be installed on your 
system with the msttcorefonts 
package from the Multiverse 
repository. Gnome-look.org has lots 
of truetype fonts to choose from. 
There are several ways to install 
them, the simplest being to just 
download a compressed archive of 
fonts and extract it to ~/.fonts 
(remember, that's a hidden folder).

That should be enough for most 
systems. If you find that the fonts 
don't show up in any applications, 
run this command in a terminal, and 
restart the applications.

fc-cache -f -v ~/.fonts

Truetype fonts have a .ttf 
extension, and usually come in a 
compressed archive like .tar.gz.

This contains clipart for 
GNU/Linux and other open 
source projects. See if you find 
anything that interests you here.

These are collections of 
system sounds. Unfortunately, 
they're usually just a bunch of 
sound files, and you have to 
manually select each type of 
system sound for each 
corresponding file. To do so, click 
System > Preferences > Sound 
then the Sounds tab.

The sound files are usually ogg 
files. Ogg Vorbis is a free-as-in-
freedom alternative to restricted 
MP3.

Mouse themes 
change your mouse 
cursors, also called 
pointers. Download a 



23

pack, and install it using System 
> Preferences > Appearance > 
Install. You can find your mouse 
themes under Customize > 
Pointers.

If you're running Compiz Fusion, 
you'll always want to tell it to use 
the same mouse theme. Click 
System > Preferences > 
Advanced Desktop Effects 
Settings > General Options, and 
change the value of the cursor 
theme field to the exact name of 
your theme. Make sure you 
respect case.

Qt apps (KDE apps) use KDE's 
mouse theme. You can customize 
it by installing and running 
kcontrol. Mouse themes have the 
.tar.gz extension.

This is almost like 
brainstorm.ubuntu.com, except 
it's for GNOME. Plus it includes 
conceptual art. You can post your 
ideas and design documents here.

Cairo clock is a 

small clock widget that can be 
installed from the repositories. Its 
package name is cairo-clock. It 
basically transforms the look of your 
analog clock. Download one from 
gnome-look.org, open it and extract 
it to ~/.cairo-clock/themes . You will 
need to make that directory yourself. 
To do so, make sure you have 
enabled viewing of hidden files.

Cairo clock themes are generally 
downloaded inside a compressed 
archive with the .tar.gz extension.

You should know what these are. 
Ubuntu comes with a lot of them by 
default. Just load System > 
Preferences > Screensaver to select 
one.

Screensavers are actually 
programs, which means there are 
lots of different ways to install them. 
Just follow the instructions in the 
description and you should be fine.

Lock dialogs are also under this 
category. A lock dialog is the window 
you see after you lock the screen, 
and you want to return to your 
session. You can customize this as 
well. Follow the instructions in each 

lock dialog's description. If it 
asks you to edit a gconf key, just 
run and use gconf-editor.

Nautilus is the default file 
explorer that comes with GNOME 
and Ubuntu. When you click on 
Places > Home Folder, you're 
using Nautilus.

You can extend Nautilus' 
functionality using scripts; think 
of them as extensions, if you 
like. Simply download one from 
gnome-look.org and extract the 
archive into ~/.gnome2/nautilus-
scripts (remember to enable 
viewing hidden folders). That's it!

Scripts don't have extensions, 
but they're usually contained 
inside a compressed archive: 
either .tar.gz or .tar.bz2.

Enjoy your new powers of 
customization! If you're still 
hungry for more, I'd like to 
mention art.gnome.org, ubuntu-
art.org, docks like AWN, cairo-
dock and Kiba dock, and my still-
in-development project complete-
look hosted on launchpad.net.

http://brainstorm.ubuntu.com
http://art.gnome.org
http://ubuntu-art.org
http://ubuntu-art.org
http://launchpad.net

